BMS - how does it work? - Page 2 - Electrical (Mk5 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!



Photo

BMS - how does it work?


  • Please log in to reply
12 replies to this topic

#11 kyutu

kyutu

    Advanced Member

  • Members
  • 37 posts
  • Vehicle Driven:MK5 1.5 Econetic

Posted 18 April 2021 - 04:07 PM

*
POPULAR

What settings did you have to change to accommodate the AGM battery, please? 

 

At first I didn't make any changes, but then realized I should edit the battery CCA/Capacity that the car is set to using Forscan to be closer to what the new battery is.  Forscan didn't have an exact match (800 and 80 in this case) so I just went for whatever was closest, I think it's currently at 700/80 or 800/70 or something...I would have to check.

 

It literally just worked once I physically made the change, the settings I changed would be more for proper charging during use/driving.

 

EDIT:  Oh and did a BMS reset which you can easily do without the need for any tools/software.

 

EDIT #2:  Added a picture showing the remaining gap between the leading edge of the battery to the airbox, plenty of room left!

Attached Thumbnails

  • Exide.jpg

Edited by kyutu, 18 April 2021 - 04:12 PM.

  • Amun likes this

Econetic 1.5 Titanium 2015


#12 Amun

Amun

    Just Joined TF!

  • Members
  • 9 posts
  • Vehicle Driven:Mondeo
  • Name:Ian Smith
  • Location:Norfolk

Posted 18 April 2021 - 10:15 PM

 

What settings did you have to change to accommodate the AGM battery, please? 

 

At first I didn't make any changes, but then realized I should edit the battery CCA/Capacity that the car is set to using Forscan to be closer to what the new battery is.  Forscan didn't have an exact match (800 and 80 in this case) so I just went for whatever was closest, I think it's currently at 700/80 or 800/70 or something...I would have to check.

 

It literally just worked once I physically made the change, the settings I changed would be more for proper charging during use/driving.

 

EDIT:  Oh and did a BMS reset which you can easily do without the need for any tools/software.

Many thanks for the info :-)



#13 bigi

bigi

    Conversmod & Powermod UK Install & Support

  • Members
  • 1309 posts
  • Vehicle Driven:Mondeo 66 Tit 180
  • Name:Ian
  • Location:cheshire

Posted 25 April 2021 - 07:43 PM

i swapped my battery for the Varta F21 AGM 110 battery (80ah/800CCA). battery had been off for about 4 hours so it went on and after 5 minutes of driving stop start started working.  i haven't changed the BS setting yet though - oddly its set like a lot of people find - varta 90/800 - which clearly the old 70/700 wasn't!  As you say, there isn't an 80/800 AGM option, so wonder which is more important - the CCA or the Ah to get accurate?


ConversMod and PowerMod UK installer.  Mileage correction, module recovery and Mod advice available via PM and forum.  Here to help!





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users