Have you done anything with your Fiesta - Ford Fiesta Mk7 Forum - (2008-2017) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!



Photo

Have you done anything with your Fiesta

engine rattle

  • Please log in to reply
4 replies to this topic

#1 mondy zetecs

mondy zetecs

    Clever Clauggs

  • Members
  • 4219 posts
  • Vehicle Driven:Mondeo 2.5l v6 2002
  • Name:Harry
  • Location:N.Yorkshire

Posted 05 April 2021 - 09:20 AM

There is a rattle on start up and whilst driving,too cold to investigate snow here,

Hoping its a pulley and not something major on this 3 cylinder engine.


Fiesta 1.0 ecoboost 2014


#2 mondy zetecs

mondy zetecs

    Clever Clauggs

  • Members
  • 4219 posts
  • Vehicle Driven:Mondeo 2.5l v6 2002
  • Name:Harry
  • Location:N.Yorkshire

Posted 05 April 2021 - 10:04 AM

Scrub the rattle ,turns out its a school boy error or senile moment,

Left the oil cap off what a plonker,luckily cap was still in a recess

part so not lost and only a little oil to wipe up.


Fiesta 1.0 ecoboost 2014


#3 mondy zetecs

mondy zetecs

    Clever Clauggs

  • Members
  • 4219 posts
  • Vehicle Driven:Mondeo 2.5l v6 2002
  • Name:Harry
  • Location:N.Yorkshire

Posted 01 May 2021 - 07:06 PM

My mates Fiesta 2016 front washer is dead when operating stalk but when

pulling up the stalk rear works fine.

Swapped the front and rear tubes around and he now has front wash but not rear

whilst waiting for a new pump.

Is there a built in relay in the pump motor or two seperate motors.  


Fiesta 1.0 ecoboost 2014


#4 Mondygeek

Mondygeek

    dont listen to me, you'll have horsepower and no money

  • Members
  • 3201 posts
  • Vehicle Driven:Mondeo mk3 (54) tdci
  • Name:Ben
  • Location:Derby

Posted 02 May 2021 - 03:09 AM

*
POPULAR

My mates Fiesta 2016 front washer is dead when operating stalk but when
pulling up the stalk rear works fine.
Swapped the front and rear tubes around and he now has front wash but not rear
whilst waiting for a new pump.
Is there a built in relay in the pump motor or two seperate motors.


I was called out to a same problem with the same year fiesta, it was the stalk itself, the push switch fails, if you're pretty aggressive with it you can get them to work but the permanent fix would be another complete stalk
  • mondy zetecs likes this

#5 mondy zetecs

mondy zetecs

    Clever Clauggs

  • Members
  • 4219 posts
  • Vehicle Driven:Mondeo 2.5l v6 2002
  • Name:Harry
  • Location:N.Yorkshire

Posted 02 May 2021 - 09:11 AM

Thanks Ben,mates not going to be happy buying a new stalk his fridge/freezer

just blown as well :mad:  


Fiesta 1.0 ecoboost 2014






Also tagged with one or more of these keywords: engine rattle

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users