Random! - Page 3 - Diesel Engines (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Random!


  • Please log in to reply
21 replies to this topic

#21 stephenbennett1979

stephenbennett1979

    Likes to chat

  • Members
  • 89 posts
  • Vehicle Driven:Ford Mondeo Mk 4
  • Name:Stephen Bennett
  • Location:West Sussex

Posted 10 April 2021 - 03:14 PM

Breaking News

Randomly I’ve kept my laptop out there just in case and engine malfunction sign came on and limp mode I’m now getting these codes picture. Vapoursier glow plug?819e35ac80c7423f7eca46bdcd7bd127.jpg
fe3de246530675353551f862bf26980e.jpg


Sent from my iPhone using Tapatalk

#22 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 29176 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 10 April 2021 - 08:27 PM

Looks that way, glowplug may have failed. Check all fuses first.

 

 

Don't think the cheap aftermarket ones are as good as a genuine one,

maybe worth the extra to fit a genuine one if that is the problem.


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users