Speedometer change Galaxy tdci 2009 - airbag light problem - Ford Galaxy Forum - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Speedometer change Galaxy tdci 2009 - airbag light problem


  • Please log in to reply
1 reply to this topic

#1 smetin

smetin

    Just Joined TF!

  • Members
  • 9 posts
  • Vehicle Driven:Ford Galaxy
  • Name:Salim Metin
  • Location:The Netherlands

Posted 03 March 2021 - 12:43 PM

Hi all,

The lcd panel of my Galaxy mk3 stopped workig. I could replace the lcd part, but  I bought a used Speedometer convers+  ( color edition).

It looks just a more better than the old panel. See attached files.

My Galaxy is  2.0 tdci of the year 2009 the new installeed speedometer comes from Mondeo 2.0 tdci of 2010. 

 

Almost everything works fine.. 

Two problems with the 'new' speedometer: 

 - the airbag light stays on

-  the seatbelt warning light/sound does not work

 

 

With a universal OBD scanner I was not able to read/delete airbag error. Disconnecting battery for an hour did not help.

To activate the seatbelt warning, I used the tip of 9 times click-on/click-off  the seatbelt, it dit not work.

 

 

When the old odometer is replaced I got no problems with airbag light and disabled seatbelt warning.

Can anyone help me?

 

 

 

 



#2 smetin

smetin

    Just Joined TF!

  • Members
  • 9 posts
  • Vehicle Driven:Ford Galaxy
  • Name:Salim Metin
  • Location:The Netherlands

Posted 12 March 2021 - 02:08 PM

Hi guys, the problem mentioned above is fixed by replacing the 2010 speedometer convers+ from an other one convers+ of 2008 model.

The issue with airbag light was caused by to new firmware of the 2010 IPC. 






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users