Bi-Xenon lights flickering - Electrical (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Bi-Xenon lights flickering


  • Please log in to reply
5 replies to this topic

#1 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2608 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 03 March 2021 - 10:52 AM

Hi,

 

My Xenon lights have recently started flickering every so often, it's like they are igniting (similar to when first turning on headlights) but without doing the level test. Seems to be occurring randomly and happens when driving steady, accelerating steady and hard, turning (bends, junctions). Near side started to do it at first but I think the offside is now doing it too.

 

I had a quick search on the net and other forums suggest that it is most likely the ballasts. I've not had a look yet but I did change the bulbs in 2014 for Osram cool blue intense (D1S bulbs), so I can refit the originals as a test.

 

Any thoughts please?

 

Thanks.


Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.


#2 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2608 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 05 March 2021 - 08:22 AM

Here's a video of it when it happens. https://youtu.be/67XW85t4iMc

 

This is what happens when the lights are turned 'on' https://youtu.be/1acArNn6D50

 


Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.


#3 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2608 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 17 March 2021 - 01:05 PM

Well, I re-fitted the original bulbs and they haven't flickered on the two occasions that I've driven in the dark.

 

Will try the Cool blue intense bulbs again soon.


Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.


#4 SteveyG

SteveyG

    Clever cloggs

  • Members
  • 1582 posts
  • Vehicle Driven:Mondeo Mk4.5 TXS 2.2
  • Name:Steve
  • Location:cambridgeshire

Posted 17 March 2021 - 01:30 PM

Sorry I meant to reply before. It's usually a sign of failure of the lamps or ballast as you've found. No easy way to diagnose other than swapping out for known good items.



#5 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2608 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 17 March 2021 - 02:28 PM

Thanks Steve. Hoping it's the bulbs rather than ballasts, though would be a little disappointed at their lifespan.


Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.


#6 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2608 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 18 April 2021 - 08:21 AM

*
POPULAR

Well, it's been 4 weeks since I re-fitted the Cool Blue Intense bulbs. Not been out in the dark much but initially they were still flickering, though not as much, but not at all on the last two 30 min drives this week, weird.

 

I did buy some replacements the other week, looks like Osram have changed the colour temperature in the new bulbs. (New bulbs in the Duobox)

bulbs.JPG


  • SteveyG likes this

Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users