Mk7 Alarm keeps going off after battery replacement - Ford Fiesta Mk7 Forum - (2008-2017) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Mk7 Alarm keeps going off after battery replacement

battery mk7 alarm replacement replaced

  • Please log in to reply
3 replies to this topic

#1 Carracer12

Carracer12

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:2009 Fiesta Titanium
  • Location:United Kingdom

Posted 28 February 2021 - 05:57 PM

Hi,

I replaced the battery in my 2009 fiesta 1.4 titanium yesterday and ever since, the alarm has been going off (maybe every 2 hours?) and I think my neighbours hate me...
I've slammed the doors, bonnet and boot shut to make sure they weren't slightly open or anything, but it hasn't helped. Everything else works, the radio, windows, lights etc and it drives perfectly so I'm not really sure what could be causing it. As I mentioned, I changed the battery yesterday, maybe there is a step I missed where I need to let the car know somehow?

 

I've had the suggestion to double check and clean the ground connection, but the car runs ok so I'm not 100% sure if that's the issue.

Any help would be appreciated greatly!



#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 29176 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 28 February 2021 - 11:53 PM

Faulty bonnet switch?


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#3 Carracer12

Carracer12

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:2009 Fiesta Titanium
  • Location:United Kingdom

Posted 02 March 2021 - 12:55 PM

Faulty bonnet switch?

I had an issue with the bonnet switch when I got the car 3 years ago, got it replaced under warranty so don't think it should be that. Especially since the car doesn't give me any "bonnet open" warnings when I drive like it did the first time around.

 

I read elsewhere that the boot switch could also be the issue, apparently adjusting it slightly could help



#4 Carracer12

Carracer12

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:2009 Fiesta Titanium
  • Location:United Kingdom

Posted 02 March 2021 - 04:33 PM

I've started getting the boot open warning. So I've tried the trick of moving the U-shaped shackle up/towards me at the opening of the boot. It's still going off after WD40-ing the mechanism as well so I'm lost really as to what I can do


 






Also tagged with one or more of these keywords: battery, mk7, alarm, replacement, replaced

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users