Mark 2 1996 Mondeo. Speedo and Fuel Gauge has emotional problems - Electrical (Mk1/Mk2 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Mark 2 1996 Mondeo. Speedo and Fuel Gauge has emotional problems


  • Please log in to reply
1 reply to this topic

#1 ChrisMcBard

ChrisMcBard

    Member

  • Members
  • 16 posts
  • Vehicle Driven:MK1 Ford Ranger XLT
  • Name:Chris McBard
  • Location:Essex

Posted 22 February 2021 - 10:45 AM

Hi guys.

My Speedo and Fuel gauge have become a bit confused with themselves. The speedo cuts out from time to time and registers nothing. The rev counter also died briefly but seems to have come back to life.

The fuel gauge is strange. When I filled it up, it stayed where it was, then the fuel light illuminated and it slowly went up. Then the light goes off and it stops. Basically does this on and off until it registers the tank's full level.

I've been reading and it seems it could be corrosion to the back of the cluster and/ or the speedo sensor?
Any advice for replacing the sensor?

Thank you!



#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 29167 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 22 February 2021 - 09:54 PM

Voltage issues?


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users