Whooshing noise from 2.0tdci on acceleration only - Ford Galaxy Forum - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Whooshing noise from 2.0tdci on acceleration only


  • Please log in to reply
2 replies to this topic

#1 steviec2000

steviec2000

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Galaxy
  • Name:Steven C
  • Location:Rotherham

Posted 18 February 2021 - 06:04 AM

Hi, I have a 2011 Galaxy 2.0tdci. I've  noticed a whistling noise when accelerating from the engine bay. Followed by an engine check light.

If I drive slowly the whistling does not appear nor the check engine light.

Could this be a split pipe? If so, any ideas on which to check and where they are located?



Thanks.

#2 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2599 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 18 February 2021 - 07:25 AM

Sounds like a split intercooler hose. Check the big hose coming out of the intercooler.

 

I'm not massively familiar with the 2.0 diesel but have a look here for an idea of the hoses http://www.catcar.in...TE1NzM3MzYrMTMz


Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.


#3 steviec2000

steviec2000

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Galaxy
  • Name:Steven C
  • Location:Rotherham

Posted 19 February 2021 - 11:53 PM

Thank you, I'll take a look this weekend.




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users