s max 2006 2.0 tdci glow plugs controller relay - Ford S-Max Forum - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

s max 2006 2.0 tdci glow plugs controller relay


  • Please log in to reply
3 replies to this topic

#1 maly

maly

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:ford s max 2.0 tdci
  • Name:John Young
  • Location:Nottingham

Posted 14 February 2021 - 08:42 PM

Hello all , my first time, as i have not had any problems so far with my S max until the last two weeks very cold temperatures. My car is takeing

                a lot of cranking before it will start. i have tested the glow plugs in situ they seem ok, but no volts showing at the 4 pin connector on

                the top of the engine. i have been told it may be a faulty glow plug controller relay. problem is i cannot locate the relay. can anyone

                help me



#2 Mondeo2013

Mondeo2013

    Likes to chat

  • Members
  • 151 posts
  • Vehicle Driven:Mondeo MK 4.5

Posted 15 February 2021 - 03:45 PM

Engine fusebox. R4



#3 maly

maly

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:ford s max 2.0 tdci
  • Name:John Young
  • Location:Nottingham

Posted 15 February 2021 - 04:03 PM

Thanks Mondeo2013 , i will check that out , the glow plug controller module relay is the one i cannot find

any info on this one



#4 Mondeo2013

Mondeo2013

    Likes to chat

  • Members
  • 151 posts
  • Vehicle Driven:Mondeo MK 4.5

Posted 26 February 2021 - 04:43 PM

It`s the R4 relay in the fusebox. No glow plug module on that engine.






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users