P0132 02 sensor - Petrol Engines (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

P0132 02 sensor


  • Please log in to reply
2 replies to this topic

#1 woodspsx1

woodspsx1

    Newbie

  • Members
  • 153 posts

Posted 25 January 2021 - 12:43 PM

Quick question. 1.6 ecoboost, 75000 miles and this codes made the light come on the dash.
Is this a common fault?
The dealer is saying £300 for the sensor? Does this sound right?
Many thanks.

#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 29229 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 25 January 2021 - 06:01 PM

£30 - £70 (ish)  ??

 

https://ford.7zap.co...58/67315/#9G444

 

9G444  - Part Number  1705220

 

or

 

9F472 - Part Number  1746971

 

 

Just because the code says its the O2 sensor may not mean the sensor itself is

faulty.  There could be other reasons like an air leak or a misifre or just faulty

wiring.

 

Some live data of what the sensor is reading would be useful to help diagnose

the issue.


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#3 woodspsx1

woodspsx1

    Newbie

  • Members
  • 153 posts

Posted 26 January 2021 - 11:33 AM

Thank you. Now p0137 is in the memory too. Low voltage. On the sensor bank 1.
Am I correct the bank 1 sensor is before the cat? And the bank 2 sensor is the Hugo sensor?

Thanks you.




5 user(s) are reading this topic

0 members, 5 guests, 0 anonymous users