Acceleration and engine braking - Ford Fiesta Mk7 Forum - (2008-2017) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Acceleration and engine braking


  • Please log in to reply
2 replies to this topic

#1 Mrfrench02

Mrfrench02

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:Fiesta
  • Name:Ian
  • Location:Kent

Posted 24 January 2021 - 08:15 PM

Hi guys, new to the forum and have a query pls.
2011 fiesta 1.5 diesel with 100k on the clock. I seem to have a momentary lapse of power at every gear change. As soon as i make the change, lift the clutch and try to accelerate i have about 2 second delay before i have power again. Also when driving generally in gear and come off the gas, i feel usual engine braking for a second or two but then i feel an increase in slowing as if the brakes are sticking. I can't help but think the accelerating and engine braking are connected? Any ideas? Is the accelerator electric rather than cable controlled?

#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 29144 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 25 January 2021 - 05:04 AM

Lapse of power as in the turbo is not boosting or the revs are increasing but

not the speed (slipping clutch)?

 

What revs are you going from and to when changing up?


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#3 Mrfrench02

Mrfrench02

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:Fiesta
  • Name:Ian
  • Location:Kent

Posted 25 January 2021 - 06:55 PM

I dont think it's the clutch slipping, feels like sluggish as if u change gear too early and ur going uphill, it takes a couple of seconds to build up speed and catch up before taking off again. Perhaps the turbo?
But that wouldnt contribute to the engine braking would it? Maybe two different issues? Is there a way to test if turbo is working properly?
Revs are being changed between 2000-2500, resting at about 1750 for the next gear




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users