Number plate light - Electrical (Focus Mk3) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Number plate light


  • Please log in to reply
5 replies to this topic

#1 jondicko

jondicko

    Just Joined TF!

  • Members
  • 3 posts

Posted 16 January 2021 - 08:08 AM

I have a 2012 focus titanium x and have just noticed the number plate light stays on after the engine is turned off and the car is locked. The light is dim until you open the boot or switch on the lights. Any ideas?


Sent from my iPhone using Tapatalk

#2 Master-of-none

Master-of-none

    Clever cloggs

  • Members
  • 1566 posts
  • Vehicle Driven:1.0 125PS Focus Ti
  • Location:essex

Posted 16 January 2021 - 12:31 PM

Have you or a previous owner changed the bulbs for LEDs? They can light up with a tiny power drain.

Either

  • Install "normal" bulbs
  • find LEDs with 'canbus' resistors
  • add a resistor in parallel like this video

Weaselling out of things is important to learn,it's what separates us from the animals Except the weasel

#3 jondicko

jondicko

    Just Joined TF!

  • Members
  • 3 posts

Posted 16 January 2021 - 12:47 PM

The number plate light and boot switch are the original part it’s one sealed unit.


Sent from my iPhone using Tapatalk

#4 Master-of-none

Master-of-none

    Clever cloggs

  • Members
  • 1566 posts
  • Vehicle Driven:1.0 125PS Focus Ti
  • Location:essex

Posted 16 January 2021 - 01:51 PM

My bad, you are correct.

 

Looking at a wiring diagram, it seems the the licence plate light unit has 2 "bulbs" wired in parallel.

If one has failed then the tiny current that the BCM supplies (when off) may be enough to light one LED but not both.

Perhaps try to compare the brightness of your light to another Focus.

 

Options:

Ignore it

replace it  £££ and a fair bit of dismantling (estate but probably similar in part)

wire in a parallel resistor

Cut open the unit and solder in new LEDs


Edited by Master-of-none, 16 January 2021 - 01:53 PM.

Weaselling out of things is important to learn,it's what separates us from the animals Except the weasel

#5 jondicko

jondicko

    Just Joined TF!

  • Members
  • 3 posts

Posted 16 January 2021 - 02:14 PM

*
POPULAR

Tried a new switch unit but that one stays on as well.


Sent from my iPhone using Tapatalk
  • Schmill likes this

#6 Schmill

Schmill

    Schmill

  • Members
  • 397 posts
  • Vehicle Driven:2012 2.0 Focus TDCi
  • Location:Bedfordshire

Posted 22 February 2021 - 01:58 AM

I have noticed the same problem with mine, also whenever I turn the lights on / off the boot unlocks / unlatches. It's not the switch as I've disconnected that - now wondering loom...

2002 52 5 door Mondeo Ghia 2.0 TDCi 130 Mk3
2000 X 4 door Focus Ghia 1.6 Petrol 100

2009 59 C-Max Titanium 1.8 TDCi 125 Mk1-Facelift

2012 62 5 door Focus TitaniumX 2.0 TDCi





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users