Wiper motor - Ford Kuga Forum - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Wiper motor


  • Please log in to reply
1 reply to this topic

#1 Lee1402

Lee1402

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:Kuga
  • Name:Lee Pettit
  • Location:Westcott

Posted 04 January 2021 - 11:02 AM

Hi all my kuga 2011 wipers stopped so.i brought a new motor for it and still nothing does it need resetting of the stalk ? I've checked fues can't locate relay and it's stressing me out

#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 29206 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 04 January 2021 - 11:46 AM

Passenger compartment fuse F129 (20amps)?

 

Could be wrong but I think the only relay is the intermittent one.

 

 

Do you have auto wipers?  I would disable them for the winter if they do a single sweep

when starting the car. The wipers can freeze to the screen and it blows the fuse.


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users