LCD Display Delay Question - Ford Fiesta Mk6 & Fusion (UK Model) Forum - (2002-2008) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

LCD Display Delay Question


  • Please log in to reply
1 reply to this topic

#1 chris301up

chris301up

    Member

  • Members
  • 14 posts
  • Vehicle Driven:Fiesta Mk 6.5
  • Location:England

Posted 15 December 2020 - 03:07 PM

Hi guys. Its that time of year again where my little old Fiesta Mk6 1.4TDCI becomes difficult to start. I have posted many questions about this over the past few years but never got to the bottom of the fault.

Anyway, my question this time, which I may have asked before but cannot remember, is about the LCD screen. I notice that when I turn the ignition there is quite a considerable delay for the LCD screen to come on, (around 10 - 15 seconds) along with dials and other ancillary components before I can attempt to start the vehicle. I have tried to upload a video of this but the site has a ridiculously small files limit and won't allow this. I've even attempted to compress this, but still to no avail

Anyone have any idea why this would happen particularly during colder months?



#2 chris301up

chris301up

    Member

  • Members
  • 14 posts
  • Vehicle Driven:Fiesta Mk 6.5
  • Location:England

Posted 16 December 2020 - 12:32 PM

Have managed to take a photo of the problem, Hope this makes sense?


Dash View.jpg






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users