Ford KA 2010 Clutch? squeak after long run - Mechanical (Ka Mk2) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Ford KA 2010 Clutch? squeak after long run


  • Please log in to reply
1 reply to this topic

#1 paulfearn100

paulfearn100

    Just Joined TF!

  • Members
  • 1 posts
  • Vehicle Driven:ford ka 2010
  • Name:Paul Fearn
  • Location:burton

Posted 03 December 2020 - 10:03 PM

Ford KA 2010 30,000 miles only , Clutch? pedal? makes squeak after long run

 

The clutch has started making a loud squeaky sound when you press and lift off the pedal. This only seems to start after the car has been running for a good time with a lot of gear changes  and continues when the engine is turned off but once its been left for a while it stops. So when you drive the next day the sound has gone

 

typical i have booked it in the the garage and sent them videos but they have refused to change any parts (under warranty) and cant find the noise or where it coming from Because its always ok for them.

 

2 x videos of noise

 

 


 



#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 28833 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 10 December 2020 - 05:44 PM

Clean the shaft and use a rubber safe grease to lubricate it.  Garage unlikely to replace it unless

it actually fails.

 

 

 


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users