Mondeo Mk3 Turbo issues - Page 3 - Diesel Engines (Mondeo Mk3) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Mondeo Mk3 Turbo issues


  • Please log in to reply
21 replies to this topic

#21 Jonnyboy07

Jonnyboy07

    Member

  • Members
  • 11 posts
  • Vehicle Driven:Mondeo TDCI
  • Name:Jonathan Wildman

Posted 26 November 2020 - 10:32 AM

*
POPULAR

Hi all, 
It appears it was the MAP sensor after all.
 
Ordered another MAP sensor, fitted it and the computer didn't turn the turbo off when the engine fired up.  The code P0235 also cleared this time whereas last time it wouldn't clear (obviously because the problem still existed).
 
For anyone else having the same issues, to clear codes P0105 - (Manifold Absolute Pressure/Barometric Pressure Circuit Malfunction) and P179A - ( Boost pressure control device malfunction) I took the MAF sensor off and cleaned that, changed the air filter, changed the turbo actuator (exact part number matches), took the EGR valve off and cleaned all the soot and dirt out from that an checked all hoses for splits.
To clear code P0235 - (Turbo/Super Charger boost sensor A circuit) I bought another MAP sensor (exact part number matches).
 
Also bought an OBD2 scanner (with CAN-BUS  connection) to read and clear codes myself; bought off Amazon for £18.99 where garage charged £60 to originally read codes - no brainer to buy one.
Obviously the low grumble noise I got at the beginning was the result of the computer turning the turbo turning off (to protect it) and it being wide open.
 
Cheers to one and all for all your input and knowledge 
 
Cheers to DavieWeegie....you were right it was the MAP sensor.

  • DavieWeegie likes this

#22 DavieWeegie

DavieWeegie

    Mondeo Lover

  • Members
  • 680 posts
  • Vehicle Driven:Mondeo ST TDCI 2005
  • Name:David
  • Location:Fife

Posted 26 November 2020 - 01:25 PM

*
POPULAR

glad you got it sorted


  • Jonnyboy07 likes this

Performance Blue Mondeo ST TDCI 2005





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users