Wiring diagrams for the dvd player anyone? - Page 2 - In-Car Entertainment (Mk3 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Wiring diagrams for the dvd player anyone?


  • Please log in to reply
15 replies to this topic

#11 dojj

dojj

    Resident Wrestling Legend

  • Members
  • 3958 posts
Garage View Garage

Posted 04 December 2020 - 05:40 PM

*
POPULAR

got this and so i'm not trying to figure out how to plug it together lol

129720385_3165590213546284_1032891343179


  • FeZZy1441 likes this

mk3 mondeo ghia x estate 2.0 auto with:

362mm 6 pot ap stoppers lurking behind some 8 x 18 comps
tv fitted to facelifted dash + headrest screens for both kids
full st kit + powerfolds w/puddlelights with jp stainless exhaust
shonky n/s/f rattle fixed by totd whoopie!
most of the chrome bits done


#12 ST56

ST56

    Clever cloggs

  • Members
  • 2229 posts
  • Vehicle Driven:Titanium X 210PS
  • Location:Cornwall

Posted 04 December 2020 - 08:16 PM

9D2C4BE9-333A-484C-A850-8E0B5A23E1C6.jpeg 631CED5C-F721-49C6-914F-FB5187DDFD26.jpeg

 

Hi

 

Harness plugs into back of units like this photo. The spare black connector connects with grey cable coming from side of box. This connects to controls at back of armrest and up through seat backs to monitors.

 

Second photo shows the full circuit.

 

Peter


Edited by ST56, 04 December 2020 - 08:29 PM.

MK5 Mondeo 5 Door Hatch 210PS Titanium X Full Bodykit on 19" Y-Spoke Wheels.
Previously Mondeo MK3 2.2 ST Tdci. (ST56MON).

Previously Mondeo MK2 ST200.

Previously Sierra XR4x4.

Previously Escort XR3i, Capri, Sierra, Escorts RS2000, RS1600, Mexico & 1300GT.
.

#13 dojj

dojj

    Resident Wrestling Legend

  • Members
  • 3958 posts
Garage View Garage

Posted 08 February 2021 - 10:58 PM

it's a bit crap the video, but i've got power to the dvd player but still nothing works

 

i've even pointed a remote at it and fiddled with buttons but nothing works

 

and there are 3 different dvd players and i've got 2 extra boxes to fiddle with as well but still nothing

 

anything else i can check please?

 

thanks

 


mk3 mondeo ghia x estate 2.0 auto with:

362mm 6 pot ap stoppers lurking behind some 8 x 18 comps
tv fitted to facelifted dash + headrest screens for both kids
full st kit + powerfolds w/puddlelights with jp stainless exhaust
shonky n/s/f rattle fixed by totd whoopie!
most of the chrome bits done


#14 FeZZy1441

FeZZy1441

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:ST220

Posted 23 February 2021 - 04:03 PM

Hi, I'm solving a similar problem. I already have the whole set and I have 3 cables left to connect. Two orange-green and one black-red. The thinner orange-green comes from the DVD module and the other two thicker ones come from the player. Can anyone advise me which cable to connect to which source? Thank you.
 



#15 dojj

dojj

    Resident Wrestling Legend

  • Members
  • 3958 posts
Garage View Garage

Posted 23 February 2021 - 09:00 PM

*
POPULAR

i've literally just come back in from refitting the seat

 

had you asked 2 days ago the car was in bits as i had to do some stuff :(

 

the good news is that the dvd player is now working, well, the screens are, you have to point the remote to the screens and i was pointing it to the dvd player

 

tomorrow i'm going to find a dvd to play so i might have another little poke around for the wires you mention, but i think they are the ones that go to the head unit to power everything up


  • FeZZy1441 likes this

mk3 mondeo ghia x estate 2.0 auto with:

362mm 6 pot ap stoppers lurking behind some 8 x 18 comps
tv fitted to facelifted dash + headrest screens for both kids
full st kit + powerfolds w/puddlelights with jp stainless exhaust
shonky n/s/f rattle fixed by totd whoopie!
most of the chrome bits done


#16 FeZZy1441

FeZZy1441

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:ST220

Posted 24 February 2021 - 12:29 PM

The black-red one should be grounded and the rest for the power supply. I tried it now, but without results. I tried to put black-red on the holder around the battery and the rest on the + battery in the car, but apparently that's not the way :-D






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users