car hiccups at motorway speeds and disengages cruise control: EGR valve fault code; injector fault code - Page 2 - Diesel Engines (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

car hiccups at motorway speeds and disengages cruise control: EGR valve fault code; injector fault code


  • Please log in to reply
13 replies to this topic

#11 helicopterandy

helicopterandy

    Member

  • Members
  • 14 posts
  • Vehicle Driven:Mk4 Diesel Mondeo
  • Name:Andy B
  • Location:Shropshire

Posted 26 September 2020 - 11:37 AM

Andy B, did you replace the intake your self? Heard it’s a bitch to get off you run into any issues or have any tips on how to remove with ease?

My EGR is causing this very issue and need to get it off to clean to see if it’s goosed and need to buy a new one.

 

Hiya Sean,

 

all i've actually done so far is apray two cans of EGR cleaner up the air intake and order an EGR valve actuator which I'm gonna replace (4 bolts and a plug).

 

by intake do you mean the air intake or the part the EGR valve itself is attached to?

 

the air intake was easy to get off and a nightmare to get back on to the air filter box. had to take the housing [box] for the ait filter out to get the air intake hose back on so i didn't dmaage the seal.

 

in the end a bit of spit and some wiggling from the side of the air intake hose taht was a bit bulging worked for me

 

Andy B



#12 TheAntman

TheAntman

    Likes to chat

  • Members
  • 59 posts
  • Vehicle Driven:Mondeo Sport
  • Name:Tony Ford
  • Location:Leigh-on-sea, Essex

Posted 26 September 2020 - 04:40 PM

*
POPULAR

If anyone finds themselves in need of replacing the inlet manifold, I am currently in the process of refurbishing my old one (i.e. giving it a thorough clean in my media blaster cabinet).

My engine is the 125HP QYBA variant, but I believe the manifold is common across all 1.8 TDCI variants.


  • helicopterandy likes this

#13 Seanmcghee88

Seanmcghee88

    Member

  • Members
  • 10 posts
  • Vehicle Driven:Form Mondeo 1.8 TDCI
  • Name:Sean McGhee
  • Location:Burnley

Posted 27 September 2020 - 01:26 PM

I’ve replaced the actuator already and I have two cans of Wynn’s EGR cleaner on the way so hopefully that sorts the issues I’m having which are the same as yours.

Did the spray improve your problem?

Just hope I don’t have to replace the intake manifold if the EGR if goosed as they only ever seem to go up in price!

If I do need a new one though at least Antman might come in handy haha

#14 helicopterandy

helicopterandy

    Member

  • Members
  • 14 posts
  • Vehicle Driven:Mk4 Diesel Mondeo
  • Name:Andy B
  • Location:Shropshire

Posted 27 September 2020 - 01:30 PM

hiya,

 

the spray worked wonders - but not until half yuwa through the second can

 

we had a flat spot under low speed accelration, which has gone

 

- no smoke on cold start up, at all

 

- no smoke under heavy acceleartion

 

- more power and sounds better too

 

yes wynn's worked wonders!!

 

hope you get yours sorted!!!

 

andy b

I’ve replaced the actuator already and I have two cans of Wynn’s EGR cleaner on the way so hopefully that sorts the issues I’m having which are the same as yours.

Did the spray improve your problem?

Just hope I don’t have to replace the intake manifold if the EGR if goosed as they only ever seem to go up in price!

If I do need a new one though at least Antman might come in handy haha






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users