Squealing noise when air con is on - Air-Con / Heating (Mk3 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Squealing noise when air con is on


  • Please log in to reply
3 replies to this topic

#1 Jbarret

Jbarret

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Ford Mondeo M3
  • Name:Ms Julie A Barrett
  • Location:Salford

Posted 14 September 2020 - 07:40 PM

I have a Ford Mondeo M3 2006 - My aircon squeals when it's turned on. It appears to be intermittent. When its on full blast, the noise stops.
I had it recharged a couple of days ago and it seems to of gotten worse since then. Any ideas?

Edited by Jbarret, 14 September 2020 - 07:43 PM.


#2 Communist

Communist

    Mk3 4 LYFE

  • Members
  • 261 posts
  • Vehicle Driven:2005 Mondeo 1.8
  • Name:Karl Marx
  • Location:People's Republic of Dorset

Posted 15 September 2020 - 09:53 PM

Is this a squealing from the engine bay or from the interior of the car? Does the noise only happen when the climate control says AC or does it also happen if you press the AC button so it says ECO?

If it's from the interior on the passenger side, then the blower fan needs looking at. It's very easy to get it out, there is a piece of matting underneath the glovebox. Pull that down, then there are three torx screws. The fan drops straight out. You do not need to remove the glovebox, despite what the haynes manual says! Check the fan moves nice and smoothly, maybe lubricate it. Replacing it with one from a scrapyard is another option, they don't cost much.

If it's the engine bay then it'll be the compressor or the belt. Do you get the noise if you run the engine and turn on the heated screens and headlights?

Edited by Communist, 15 September 2020 - 09:56 PM.


#3 Jbarret

Jbarret

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Ford Mondeo M3
  • Name:Ms Julie A Barrett
  • Location:Salford

Posted 17 September 2020 - 12:12 PM

Hi,
I'd say it was the interior on the passenger side. So ill try the blower fan and let you know how I get on.
Thank you!!!

#4 Jbarret

Jbarret

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Ford Mondeo M3
  • Name:Ms Julie A Barrett
  • Location:Salford

Posted 19 September 2020 - 10:16 AM

Lube worked a treat! No more noise.

Thanks 😊




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users