all washer jets stopped working - Electrical (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!



Photo

all washer jets stopped working


  • Please log in to reply
20 replies to this topic

#1 lgwjames

lgwjames

    Likes to chat

  • Members
  • 163 posts
  • Vehicle Driven:mondeo edge 2008
  • Name:james

Posted 13 September 2020 - 09:05 AM

Have had a problem since the garage did my cam belt of it always saying no water in my washer yet is full

 

today on the way to work, none of my washer jets are working. front and rear wipers move

 

went to top up water ( did it a week ago ) and only had 2 cups of top up to do, so it wasnt low

 

checked fuse 37 in front and seems ok

 

cant hear a pump on using

 

any ideas



#2 brian22640

brian22640

    Titmk4

  • Members
  • 104 posts
  • Vehicle Driven:Mondeo Titanium 09
  • Name:Brian
  • Location:United Kingdom

Posted 13 September 2020 - 09:15 AM

Have had a problem since the garage did my cam belt of it always saying no water in my washer yet is full

today on the way to work, none of my washer jets are working. front and rear wipers move

went to top up water ( did it a week ago ) and only had 2 cups of top up to do, so it wasnt low

checked fuse 37 in front and seems ok

cant hear a pump on using

any ideas

. Fit a new/secondhand pump very easy to do I bought one from euro carparts very expensive and very two of them broke within a week so I got my money back and went to the local breakers yard paid £5 for one still working months later


Sent from my iPhone using Tapatalk

It's only a Mondeo "yes but it's my Mondeo"


#3 mike4369

mike4369

    Big Megger

  • Members
  • 3016 posts
  • Vehicle Driven:2014 C Max 1.6TDCi
  • Name:Mike
  • Location:Brecon

Posted 13 September 2020 - 10:46 AM

I would take car back to the garage and get them to sort it - they most likely did something when changing the cam belt as it is necessary to take wheel arch cover off and water bottle is behind that so could have disturbed pump wiring.



#4 brian22640

brian22640

    Titmk4

  • Members
  • 104 posts
  • Vehicle Driven:Mondeo Titanium 09
  • Name:Brian
  • Location:United Kingdom

Posted 13 September 2020 - 01:41 PM

I would take car back to the garage and get them to sort it - they most likely did something when changing the cam belt as it is necessary to take wheel arch cover off and water bottle is behind that so could have disturbed pump wiring.

washer pump on mine is on the gearbox side not sure if its the same for all Mondeo's MK4


It's only a Mondeo "yes but it's my Mondeo"


#5 Mark M

Mark M

    TF regular

  • Members
  • 1343 posts
  • Vehicle Driven:Mk4 Mondeo 2.5t
  • Name:Mark
  • Location:Worthing West Sussex

Posted 13 September 2020 - 04:24 PM

I would take car back to the garage and get them to sort it - they most likely did something when changing the cam belt as it is necessary to take wheel arch cover off and water bottle is behind that so could have disturbed pump wiring.

washer pump on mine is on the gearbox side not sure if its the same for all Mondeo's MK4

All mk4's should have the washer bottle and pump etc on the passenger side

RamAir Pod Filter   -   Elevate FST225 Top Pipe   -   Airtec FMIC   -   Scorpion Downpipe   -    Scorpion Cat Back Exhaust   -   ECV Valve   -   RS DMF + Clutch Kit   -   Bluefin Stage 2

 

Sports Rear Diffuser   -   Sports Top Front Grill   -   Sports Bottom Front Grill   -   Sports Fog Lights   -   Sport Pedal Covers   -   Dark Ice Designs Auto Lift Boot Struts   -   Dark Ice Designs Bonnet Rams   -   Dark Ice Designs Short Shift Kit   -   Auto Mirror Mod   -   Interior LED Conversion   -   Nextbase 402 and 512 Dashcams  -  Convers Mod

 

295bhp & 450nm of fun, but can still give 38mpg  :driving: 


#6 lgwjames

lgwjames

    Likes to chat

  • Members
  • 163 posts
  • Vehicle Driven:mondeo edge 2008
  • Name:james

Posted 15 September 2020 - 05:22 AM

Thanks all. Ordered a pump and sensor. £13 and yes is passenger side

Sent from my SM-G965F using Tapatalk

#7 lgwjames

lgwjames

    Likes to chat

  • Members
  • 163 posts
  • Vehicle Driven:mondeo edge 2008
  • Name:james

Posted 15 September 2020 - 11:28 AM

I would take car back to the garage and get them to sort it - they most likely did something when changing the cam belt as it is necessary to take wheel arch cover off and water bottle is behind that so could have disturbed pump wiring.

 

hi mike, this was months ago they did it.

 

 

Have had a problem since the garage did my cam belt of it always saying no water in my washer yet is full

today on the way to work, none of my washer jets are working. front and rear wipers move

went to top up water ( did it a week ago ) and only had 2 cups of top up to do, so it wasnt low

checked fuse 37 in front and seems ok

cant hear a pump on using

any ideas

. Fit a new/secondhand pump very easy to do I bought one from euro carparts very expensive and very two of them broke within a week so I got my money back and went to the local breakers yard paid £5 for one still working months later


Sent from my iPhone using Tapatalk

 

 

hi brian, can i just take the P/S headlight out and get to it from there? or do i have to do under the car?



#8 Mark M

Mark M

    TF regular

  • Members
  • 1343 posts
  • Vehicle Driven:Mk4 Mondeo 2.5t
  • Name:Mark
  • Location:Worthing West Sussex

Posted 15 September 2020 - 06:59 PM

You could possibly do the pump through the fog light hole or more likely from underneath if you remove the front splash shield. As you're doing the level sensor as well though you are most likely going to have to remove the bumper which would make the pump swap even easier.

RamAir Pod Filter   -   Elevate FST225 Top Pipe   -   Airtec FMIC   -   Scorpion Downpipe   -    Scorpion Cat Back Exhaust   -   ECV Valve   -   RS DMF + Clutch Kit   -   Bluefin Stage 2

 

Sports Rear Diffuser   -   Sports Top Front Grill   -   Sports Bottom Front Grill   -   Sports Fog Lights   -   Sport Pedal Covers   -   Dark Ice Designs Auto Lift Boot Struts   -   Dark Ice Designs Bonnet Rams   -   Dark Ice Designs Short Shift Kit   -   Auto Mirror Mod   -   Interior LED Conversion   -   Nextbase 402 and 512 Dashcams  -  Convers Mod

 

295bhp & 450nm of fun, but can still give 38mpg  :driving: 


#9 tellmah

tellmah

    Big Megger

  • Members
  • 3005 posts
  • Vehicle Driven:Mondeo 2.5T Tit X
  • Name:Martin
  • Location:Greater Manchester

Posted 16 September 2020 - 11:21 AM

Several years ago mine packed up with crud in it, so whilst it was being serviced, they cleaned the pump out and charged me £30 for doing it, which works out at about 15-20 minutes labour time. Based on that, there can't be much to remove to get to it.

 

I would guess it's either the FNS wheel arch or the undershield.




Mondeo 2.5T Tit X 2008, in panther black, sportspack and privacy glass. Never seem another model like it in my area.

 

Ford Escort, Morris Marina, Ford Granada, VX Astra Est, VX Cavalier x2, Rover 820, MK2 Mondeo


#10 lgwjames

lgwjames

    Likes to chat

  • Members
  • 163 posts
  • Vehicle Driven:mondeo edge 2008
  • Name:james

Posted 16 September 2020 - 11:46 AM

Just be quoted £40 to do both so not bad

Sent from my SM-G965F using Tapatalk




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users