ford mondeo 1997 no power just hazard go on when ignition is on - Electrical (Mk1/Mk2 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

ford mondeo 1997 no power just hazard go on when ignition is on


  • Please log in to reply
2 replies to this topic

#1 stuntman132

stuntman132

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:ford mondeo 1997
  • Name:stevie
  • Location:portsmouth

Posted 04 August 2020 - 03:43 PM

please help i got no power just hazard go on when ignition is on

 

ford mondeo 1997



#2 tellmah

tellmah

    Big Megger

  • Members
  • 3005 posts
  • Vehicle Driven:Mondeo 2.5T Tit X
  • Name:Martin
  • Location:Greater Manchester

Posted 04 August 2020 - 05:12 PM

please help i got no power just hazard go on when ignition is on

 

ford mondeo 1997

You need to put articles in the appropriate forum ie, Mk 1 or 2 Mondeo electrical section, rather than general talk.

I'll ask the mods to move it for you.




Mondeo 2.5T Tit X 2008, in panther black, sportspack and privacy glass. Never seem another model like it in my area.

 

Ford Escort, Morris Marina, Ford Granada, VX Astra Est, VX Cavalier x2, Rover 820, MK2 Mondeo


#3 stuntman132

stuntman132

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:ford mondeo 1997
  • Name:stevie
  • Location:portsmouth

Posted 04 August 2020 - 05:35 PM

ok thank you im new here






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users