Glow plug light flashing - Page 4 - Diesel Engines (Mondeo Mk3) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Glow plug light flashing


  • Please log in to reply
38 replies to this topic

#31 dsmcgarry

dsmcgarry

    Just Joined TF!

  • Members
  • 7 posts
  • Vehicle Driven:Mondeo
  • Name:David McGarry
  • Location:Boston, UK

Posted 03 August 2020 - 12:43 PM

My g code is 221. Found on the plastic top not on the body though.

#32 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 28342 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 03 August 2020 - 02:22 PM

Stamped into the black plastic housing?  Strange, all the ones I have seen have been on

the metal part. Although thats not a huge amount.


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#33 dsmcgarry

dsmcgarry

    Just Joined TF!

  • Members
  • 7 posts
  • Vehicle Driven:Mondeo
  • Name:David McGarry
  • Location:Boston, UK

Posted 05 August 2020 - 10:56 AM

Bought a second hand actuator from eBay. Fitted it and hey presto. All is fine at present now. Fingers crossed!!

While pottering around town before it arrived though the engine light came on.
Is there an easy way to get rid of it?

#34 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 28342 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 05 August 2020 - 01:29 PM

If the EGR is blanked you will get the engine light on. Its fairly random though.

 

Some members didnt get the light for ages and others in a very short time/or distance.

 

There were talks of it being mapped out when blocking the EGR but it didnt seem

reliable they had the light come back on after a week or so.


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#35 DavieWeegie

DavieWeegie

    Mondeo Lover

  • Members
  • 606 posts
  • Vehicle Driven:Mondeo ST TDCI 2005
  • Name:David
  • Location:Fife

Posted 05 August 2020 - 01:42 PM

as your mentioning EML light for the EGR I've got a wierd one....

 

mines is a Euro 3, it has vac operated EGR and turbo, no electrical connections at all on either, but with my EGR deleted I get the EML light come on for insufficient flow detected then I reset it and it stays off for a random time before its back... any ideas why? I'm lost as with no electrical signals to show that its deleted how could the ECU know theres insufficient flow?


Performance Blue Mondeo ST TDCI 2005


#36 nicam49

nicam49

    Little Megger

  • Gold Member
  • 3959 posts
  • Vehicle Driven:Mondeo mk3
  • Name:Nick
  • Location:Leicestershire

Posted 05 August 2020 - 02:47 PM

Maybe something to do with the MAF and MAP sensors?
<p><p>nicam49 2002 Mondeo TDCi Ghia X Estate mk3 pre facelift Stardust Silver+Rust.[b] 308,000+miles, but been off the road since Nov 2019 after timing chain slipped during fuel pump transplant. Awaiting return of mojo

#37 dsmcgarry

dsmcgarry

    Just Joined TF!

  • Members
  • 7 posts
  • Vehicle Driven:Mondeo
  • Name:David McGarry
  • Location:Boston, UK

Posted 05 August 2020 - 03:39 PM

Egr not blanked. Everything back to normal configuration.
Light still on after having battery disconnected so that cure doesn’t work!

Will be ordering odb.

#38 DavieWeegie

DavieWeegie

    Mondeo Lover

  • Members
  • 606 posts
  • Vehicle Driven:Mondeo ST TDCI 2005
  • Name:David
  • Location:Fife

Posted 05 August 2020 - 04:17 PM

Maybe something to do with the MAF and MAP sensors?

I wouldnt have thought so as their both before the EGR, its had me scratching my head.


Performance Blue Mondeo ST TDCI 2005


#39 dsmcgarry

dsmcgarry

    Just Joined TF!

  • Members
  • 7 posts
  • Vehicle Driven:Mondeo
  • Name:David McGarry
  • Location:Boston, UK

Posted 06 August 2020 - 10:57 AM

Good news.
Came out this morning. Started car.
No lights.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users