2013 s max cruise control not working - Ford S-Max Forum - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

2013 s max cruise control not working


  • Please log in to reply
No replies to this topic

#1 MVB180

MVB180

    Just Joined TF!

  • Members
  • 4 posts
  • Vehicle Driven:S Max
  • Name:Michael Benton
  • Location:Tiptree Essex

Posted 09 June 2020 - 07:07 PM

Evening all
I’m suffering an issue with my cruise control. It won’t turn on and go into standby, it had done it last year and believed it to be the clutch switch, changed the switch and all was good. Then a few weeks ago it did the same thing so went straight back to the switch, I broke it getting it off so just replaced it but still not working.
Looked at several search’s but nothing really helping, I tried blowing air in behind the switches which didn’t work. The speed limiter is temperamental as well so thought it’s likely to be the switch’s but, when the cc switch doesn’t work or turn on but the speed limit is working ok, if u set the speed limiter and your moving using the limiter and u press the cc button it knocks it out of the SL back into standby so I think the buttons are ok so I think it’s something else on the car.
Anybody got and ideas? People have said maybe abs.
One thing, last year when it wasn’t working when I disconnected the clutch switch the cc worked perfectly even without the clutch switch plugged in?????
Any help would be very much appreciated.
Cheers




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users