Mondeo 2009 2.2 wont start - Diesel Engines (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Mondeo 2009 2.2 wont start


  • Please log in to reply
3 replies to this topic

#1 Jackmass

Jackmass

    Member

  • Members
  • 19 posts
  • Vehicle Driven:Mondeo 2.2
  • Name:Jack massey
  • Location:East london

Posted 05 June 2020 - 08:03 PM

My mondeo 2.2 2009 wont start its sounds like it goes to catch but then nothing again. Starts with easy start but then very hesitant from idle like it’s going to stall and sometimes cuts out sitting at idle rpm. It starts again straight away after being turned off not cutting out but after 5 mins it’s doesn’t start at all. There is no fault codes at all done with a snap on machine
I must include everything that has been happening from the start:
Cam belt stripped teeth (replaced with new water pump)
Snapped every rocker (replaced everything rocker with tappet)
I changed cylinder head (replaced gasket and stretch bolts to correct torque)
Put all back together with new seals and now I got this I’ve changed fuel filter, crankshaft sensor and even redone the injectors still same problem.
I really need help with this now It’s driving me mad now it’s all I think about ( sad I know)

Edited by Jackmass, 05 June 2020 - 08:06 PM.


#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 28192 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 05 June 2020 - 11:42 PM

Compression test maybe required.

 

Air in the fuel? Uses a length of clear tubing on the low pressured side.

 

When it does start will it idle properly once warmed? Have you driven it? Power all there

or lacking?

 

With all that work are you 100% sure the timing was spot on?


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#3 riikomi

riikomi

    TF regular

  • Members
  • 696 posts
  • Vehicle Driven:Mondeo 2009 2.2
  • Location:Finland

Posted 06 June 2020 - 04:44 AM

Since the engine eventually runs, I’d say that air in the fuel system would be the nr one candidate.

#4 Jackmass

Jackmass

    Member

  • Members
  • 19 posts
  • Vehicle Driven:Mondeo 2.2
  • Name:Jack massey
  • Location:East london

Posted 06 June 2020 - 09:07 AM

Hello it idles fine I have driven it but on pull away it’s always hesitant at first then after a few seconds it’s like it kicks in the powers through then I change gear and goes through the same process again. There is no air in fuel pipes but after a while the odd bubble goes through the main line which I can’t explain. Timing was spot on I had the pins in flywheel and camshaft.
What I don’t understand is why it goes to catch at first the just goes back to normal cranking over

Edited by Jackmass, 06 June 2020 - 09:16 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users