Why doesn't my DVD drive work? - Page 2 - Electrical (Mk3 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Why doesn't my DVD drive work?


  • Please log in to reply
11 replies to this topic

#11 dojj

dojj

    Resident Wrestling Legend

  • Members
  • 3814 posts
Garage View Garage

Posted 04 June 2020 - 05:15 PM

I've taken lots of pictures
But they are on my phone so are too big to upload
I'll have a go later tonight

mk3 mondeo ghia x estate 2.0 auto with:

362mm 6 pot ap stoppers lurking behind some 8 x 18 comps
tv fitted to facelifted dash + headrest screens for both kids
full st kit + powerfolds w/puddlelights with jp stainless exhaust
shonky n/s/f rattle fixed by totd whoopie!
most of the chrome bits done


#12 dojj

dojj

    Resident Wrestling Legend

  • Members
  • 3814 posts
Garage View Garage

Posted 06 June 2020 - 06:16 PM

*
POPULAR

 

Yup
Got the dvd player under the seat
Head rests either side
The thing in the rear where the ash tray used to live
Even got the remote, with new batteries
But nothing seems to be working even though everything is plugged in where it's supposed to be :(

No control module though, what is that supposed to look like?

 

 

Hi

 

My mistake attached are the pics I was thinking of, seems to be a control unit mounted under DVD.

 

Peter

 

 

had a bit of a look under the seat today and i seem to have found the issue
there are no wires going to/from the actual dvd player so that would explain why nothing works :(

 

damn!


  • raynkar and nicam49 like this

mk3 mondeo ghia x estate 2.0 auto with:

362mm 6 pot ap stoppers lurking behind some 8 x 18 comps
tv fitted to facelifted dash + headrest screens for both kids
full st kit + powerfolds w/puddlelights with jp stainless exhaust
shonky n/s/f rattle fixed by totd whoopie!
most of the chrome bits done





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users