1999 2.5 V6 SPEEDO STOPPED WORKING - Electrical (Mk1/Mk2 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

1999 2.5 V6 SPEEDO STOPPED WORKING

speedo

  • Please log in to reply
1 reply to this topic

#1 kjohns80

kjohns80

    Just Joined TF!

  • Members
  • 1 posts
  • Vehicle Driven:Mondeo 2.5 V6
  • Name:Karl Johns
  • Location:Coventry

Posted 06 April 2020 - 01:00 PM

Hi Guys,

 

 

i've got a 1999 Mondeo, 2.5 V6. The speedo has just stopped working. Is there anything obvious i can have a look for? Is there a cable that could of come loose/unplugged? 

 

Thanks for any help or advice 


Edited by kjohns80, 06 April 2020 - 01:07 PM.


#2 tellmah

tellmah

    Big Megger

  • Members
  • 2990 posts
  • Vehicle Driven:Mondeo 2.5T Tit X
  • Name:Martin
  • Location:Greater Manchester

Posted 06 April 2020 - 01:26 PM

Hi Guys,

 

 

i've got a 1999 Mondeo, 2.5 V6. The speedo has just stopped working. Is there anything obvious i can have a look for? Is there a cable that could of come loose/unplugged? 

 

Thanks for any help or advice 

You've put it in the wrong section. It should be the MK2 or 3 Mondeo. I'll ask the mods to move it for you.




Mondeo 2.5T Tit X 2008, in panther black, sportspack and privacy glass. Never seem another model like it in my area.

 

Ford Escort, Morris Marina, Ford Granada, VX Astra Est, VX Cavalier x2, Rover 820, MK2 Mondeo






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users