Mondeo 2010 2.0 tdci problems - Diesel Engines (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!



Photo

Mondeo 2010 2.0 tdci problems


  • Please log in to reply
6 replies to this topic

#1 dom195x

dom195x

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Mondeo 2.0 tdci 2010
  • Name:Dominik Fijačko
  • Location:Zavrč

Posted 06 April 2020 - 09:30 AM

Hell everyone!
So i had this problem with my Mondeo 2010 2.0 tdci 140ps UFBA engine for long. I allready have car by mechanics for 4 months.so i was driving normaly and sudenly the engibe start smoking like a lot and idling. I took it to mechanics and they said that i have problems with injector number 3. So i decided that we change all 4 and solve the problem. They change the injectors and guess what? Car wont start. They also change fuel filter oil filter, couple od electronics relays which you must change if you change injectors. And they come to conclusion that problem is in the cpu. The program is mixed up and that i need new program, but the cpu ist just fine. So i took it to the firm where they givr me original program and they coded also new injectors. Guess what? Car wont start. Have you guys any idea what is wrong? And yes, all cylinder are in good condition. So mechanicly is everything ok. Any ideas? Thank you! And sorry for bad english. 😊

#2 stephenbennett1979

stephenbennett1979

    Member

  • Members
  • 23 posts
  • Vehicle Driven:Ford Mondeo Mk 4
  • Name:Stephen Bennett
  • Location:West Sussex

Posted 06 April 2020 - 09:05 PM

Mine was a absolute nightmare to start after I replaced fuel filter despite priming correctly and following all correct procedures. Maybe that!! I had to eventually get AA out and they had just as much as a issue I had but after starting was fine.


Sent from my iPhone using Tapatalk

#3 dom195x

dom195x

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Mondeo 2.0 tdci 2010
  • Name:Dominik Fijačko
  • Location:Zavrč

Posted 07 April 2020 - 09:12 PM

Well they said to me today that they have to start again checking everything from start... so i hope they found something... i think that they probably miss something... i have no idea... on car i have done every servise on interval so every 12.000km changed oil, oil filter, air filter... every 60.000 i changed fuel filter... on 170.000 i made big servise... and now i have new injectors and new program, i dont know why wont start haha... but one thing for sure... that was my last ford.. i will not buy ford anymore 🤣

#4 turbopete1

turbopete1

    TF regular

  • Members
  • 557 posts
  • Vehicle Driven:mk4 mondeo zetec
  • Name:Peter
  • Location:spennymoor

Posted 09 April 2020 - 10:57 AM

i think they will need to code the injectors, not just fit them. are the garage aware of this and know how to do this?



#5 riikomi

riikomi

    TF regular

  • Members
  • 689 posts
  • Vehicle Driven:Mondeo 2009 2.2
  • Location:Finland

Posted 09 April 2020 - 11:30 AM

Have you checked that the intake manifold flap is not in a closed position?



#6 dom195x

dom195x

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Mondeo 2.0 tdci 2010
  • Name:Dominik Fijačko
  • Location:Zavrč

Posted 09 April 2020 - 01:56 PM

They code the injectors allready yea.... today they called me and said to me that car has started. So car is ready to pick up. But i think that they made failure somewhere and after 4 months they discovered what they made wrong 🤦‍♂️ im gonna pick my car tommorow and then i will know what was exactly wrong.

#7 EvoUK

EvoUK

    Big Buttie Megger

  • Members
  • 935 posts
  • Vehicle Driven:07 Mondeo Titanium X
  • Name:Neil
  • Location:gloucestershire

Posted 09 April 2020 - 07:49 PM

I'm pretty sure I've heard people change injectors without having to code them.




Mondeo ST24 Medium Steel Blue   NOW SOLD

 

Mondeo Mk4 Titanium X TDCI140 Panther Black with RS 18" alloys.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users