Rear fog light switch - Ford Escort Forums & Ford Orion Forums - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!



Photo

Rear fog light switch


  • Please log in to reply
3 replies to this topic

#1 Rockie

Rockie

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:Escort
  • Name:David
  • Location:N ireland

Posted 23 February 2020 - 11:24 AM

98 escort rearfog light switch stays on when lights switched on any ideas

#2 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 27864 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 23 February 2020 - 11:55 AM

Unplug the switch, do they go off?

 

Fitted any bulbs recently?  Not fitted a single filament bulb into a twin socket?


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#3 Rockie

Rockie

    Just Joined TF!

  • Members
  • 2 posts
  • Vehicle Driven:Escort
  • Name:David
  • Location:N ireland

Posted 23 February 2020 - 12:40 PM

no bulbs been changed when I put my lights on the fog light rear comes on switch on dash board will not turn off stays light changed switch same problem ?

#4 turbopete1

turbopete1

    TF regular

  • Members
  • 548 posts
  • Vehicle Driven:mk4 mondeo zetec
  • Name:Peter
  • Location:spennymoor

Posted 23 February 2020 - 03:24 PM

sounds like its getting power from somewhere it shouldnt. id be tempted to pull the relay and see what happens. coulod be a relay fault. i cant remember which one it is though, but it does sound like its getting a power supply from somewhere so assuming the replacement switch was a known good unit, relay would be my next point to check (burnt contact shorting out/welded closed or similar)

 

a 98 will be the last of the escorts (mk6/7 depending on how you number them, if you call the mk5 facelift a mk5a or a mk6) which i dont remember having issues but mk5 escorts particularly had issues with water getting into the car and corroding the fusebox, but id say its VERY unlikely a mk7/6 (whichever you prefer) will have this issue.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users