Steering was stiff - Suspension / Wheels / Brakes / Steering (Mk3 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Steering was stiff


  • Please log in to reply
4 replies to this topic

#1 chrisland

chrisland

    Little Megger

  • Members
  • 43 posts
  • Vehicle Driven:Ford Mondeo
  • Name:Christopher
  • Location:United Kingdom

Posted 07 January 2020 - 07:10 AM

A couple of weeks ago I went out in my Mondeo, as I got to the end of the road to turn left I found the steering to suddenly be very stiff. Turning right had been fine. I carried on and didn`t notice anymore problems. This me a bit so I took it to my local garage for a check over. They couldn`t find a thing wrong. I left it with them again a week later expecting them to fit new top mounts, but they were not needed as everything was as it should be. I have had no more problems since the original occurrence and the car drives perfectly normal, even my wife says t is ok and she does 250 miles a week in it.

Any ideas what could have caused this? Would it be worth flushing the PAS system? Possible column UJ ( but why have I not experienced any more problems?) even the garage were baffled.

  



#2 Mondygeek

Mondygeek

    dont listen to me, you'll have horsepower and no money

  • Members
  • 2944 posts
  • Vehicle Driven:Mondeo mk3 (54) tdci
  • Name:Ben
  • Location:Derby

Posted 07 January 2020 - 05:35 PM

*
POPULAR

A couple of weeks ago I went out in my Mondeo, as I got to the end of the road to turn left I found the steering to suddenly be very stiff. Turning right had been fine. I carried on and didn`t notice anymore problems. This me a bit so I took it to my local garage for a check over. They couldn`t find a thing wrong. I left it with them again a week later expecting them to fit new top mounts, but they were not needed as everything was as it should be. I have had no more problems since the original occurrence and the car drives perfectly normal, even my wife says t is ok and she does 250 miles a week in it.
Any ideas what could have caused this? Would it be worth flushing the PAS system? Possible column UJ ( but why have I not experienced any more problems?) even the garage were baffled.


Maybe there was air in system and it was just passing through the pump
  • chrisland likes this

#3 stevegti6

stevegti6

    Advanced Member

  • Members
  • 44 posts
  • Vehicle Driven:mondeo tdci
  • Name:Steve cotterell
  • Location:nailsworth

Posted 08 January 2020 - 10:33 AM

*
POPULAR

Try changing the power steering fluid I had the notchy steering issue which the mondeos suffer with. And after changing the fluid to the correct spec it’s as good as new. The stuff that came out was well passed it’s sell by date.


Sent from my iPhone using Tapatalk
  • chrisland likes this

#4 chrisland

chrisland

    Little Megger

  • Members
  • 43 posts
  • Vehicle Driven:Ford Mondeo
  • Name:Christopher
  • Location:United Kingdom

Posted 14 January 2020 - 05:55 AM

Thank you for your feed back on the matter. I will change the fluid as it is a cheap option.



#5 chrisland

chrisland

    Little Megger

  • Members
  • 43 posts
  • Vehicle Driven:Ford Mondeo
  • Name:Christopher
  • Location:United Kingdom

Posted 14 February 2020 - 07:53 AM

An update to my steering problem. I withdrew some fluid from the reservoir and found it was like this black oil. So with the help of a good mate who had done a few of these, we bled the system with new fluid. All I can say is what a difference this has made. It is at least 95% better. I will do it again as any old crap left in the system will be in the new oil, so I will bleed it through at some point. All in all, a cheap remedy. Thanks for the advice.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users