Mk3 High Emissions and poor idle - Ford Fiesta Mk1 / Mk2 / Mk3 Forum - (1976-1995) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Mk3 High Emissions and poor idle


  • Please log in to reply
1 reply to this topic

#1 LukeLJB

LukeLJB

    Just Joined TF!

  • Members
  • 1 posts
  • Vehicle Driven:Mk3 Fiesta Meridian
  • Name:Luke
  • Location:Norfolk

Posted 23 September 2019 - 07:03 PM

Firstly, hello all I’m new here.

I have a mk3 fiesta 1.1 that has a 1995 1.3 fiesta engine fitted.
The emissions are sky high and the idle is rough. Also it floods and won’t restart after stalling.
The ecu is still from the 1.1 engine. I have changed the MAP sensor and lambda sensor and still no change.
It’s the single point injection hcs engine.

Any recommendations please has it’s driving me insane.

Cheers guys

#2 turbopete1

turbopete1

    TF regular

  • Members
  • 577 posts
  • Vehicle Driven:mk4 mondeo zetec
  • Name:Peter
  • Location:spennymoor

Posted 24 September 2019 - 10:58 AM

ecu will be pretty basic but may need recalibrated to suite the 1.3 engine or swapped with the ECU from the 1.3 engine. also rough/high idling would alsio indicate possible vacuum hose splits/leaks.

i also seem to recall an idle speed control valve/stepper motor on these that used to give issues failry commonly back in the day but vacuum leaks and checking the fuel ecu would be topp of my list given the ecu will be calibrated for the injector sizes and duty cycles for the 1.1 which is probably a smaller nozzle than the 1.3






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users