Mk2 Fiesta - Ford Fiesta Mk1 / Mk2 / Mk3 Forum - (1976-1995) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Mk2 Fiesta


  • Please log in to reply
1 reply to this topic

#1 matty_boi88

matty_boi88

    Just Joined TF!

  • Members
  • 1 posts
  • Vehicle Driven:mk2 fiesta
  • Name:mathew weston
  • Location:kent

Posted 16 April 2019 - 06:03 PM

Hi all i have an issue with my front indicators i have tested power to them... fine but not lighting up is there a negative point and a positive/negative in the light conector... rear ones work just not hazards they stay on with hazards ... sorry not detailed ...limited knowledge electrically thanks

#2 frembrit

frembrit

    MEG Corporal

  • Lifetime Gold Member
  • 2572 posts
  • Vehicle Driven:Mondeo MK4.5
  • Name:Dave
  • Location:Somerset

Posted 16 April 2019 - 06:06 PM

can you hear the flasher relay clicking when you use the indicators? and then does it stop clicking when using the hazards? do the front indicators light up too on hazard? Could be the relay.


Mondeo 2.2 TDCI Titanium X Sport (MK4.5), Panther Black | S-Max 2.5T front brake calipers and 316mm discs |  Fuel Log

 

Now Dead - Mondeo ST24, 2000 W reg, Amparo Blue | ST170 Calipers and Discs | Goodridge Hoses | GW Decat | K&N Panel Filter | Black eyes | LPG

 

Honda Hornet, 2004, Matt Blue.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users