Ford Mondeo Titanium TDCI - Car Diaries - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!



Photo

Ford Mondeo Titanium TDCI


  • Please log in to reply
9 replies to this topic

#1 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 24 March 2017 - 08:10 PM

Well here we have a new diary for my new mondeo,
2012 Titanium 140 TDCI,
registratered as brown in colour ?, but name of colour is "Luna sky" quite like it,
Well I did buy it !

ImageUploadedByTalkFord.com1490386081.265603.jpg



Haven't got much planned to do with it but drive and enjoy!

I've put a new set of tyres on,
I give it a oil and filter change which was a f¥€#ing nightmare!
I've done a few services on mk4 mondeo's but more on peugeot 1.6 and 2.0,
Oil filter and fuel filter right next to each other and accessible with a socket !
O no not this one !!!! Can't get a socket on the oil filter because someone decided to add something to the engine blocking access to the oil filter!!!! And the fuel filter is by the tank ??
So had to buy a bent tool?, still no joy because it was a 12 sided tool in the end I had to smash it off,
I had thought about this so bought a replacement
It has a full service history with ford stamps, but I think someone has not lubed the oil seal or over tighten the cap?

Got a bargain off eBay witter tow bar and dedicated wiring,
Only fitted the towbar, just put the sockets and back plate just to see how it looked and see if they interrupt with the reverse sensors and they don't !
I've not connected the wiring yet because I need to disconnect the battery, but have no radio code !


So overall quite a good car!

ImageUploadedByTalkFord.com1490386127.984297.jpg

ImageUploadedByTalkFord.com1490386171.719407.jpg

ImageUploadedByTalkFord.com1490386209.990857.jpg


2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue

#2 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 24 March 2017 - 08:52 PM

Bit of an update, the car is running great
Had the timing belt done at 120000 miles, the car sailed trough its MOT no advisories only said the brake pads front & rear were low!.

So here's a few pics for before & after the work !
All four discs have a lip around the edges so thought change them too!
I got Brembo disc & pads, they worked out £15 more than opting for Bosch disc & pads, which is what I would of used !
Also I planned on painting the calipers too because the alloys are quite open ! & all you can see is rusty calipers !,

ImageUploadedByTalkFord.com1490387713.823515.jpg

ImageUploadedByTalkFord.com1490387775.777789.jpg

ImageUploadedByTalkFord.com1490387816.751339.jpg
All four discs were like this.

ImageUploadedByTalkFord.com1490387872.368651.jpg
Low pads.

ImageUploadedByTalkFord.com1490387948.945283.jpg
Rubbed, cleaned & ready to paint.

ImageUploadedByTalkFord.com1490388097.508123.jpg
I've only gone for a simple clean look, I wasn't going over board!.

ImageUploadedByTalkFord.com1490388237.465413.jpg
Job done !, well the fronts anyway!.
This was done Thursday, Friday is the rear !

ImageUploadedByTalkFord.com1490388344.625743.jpg

ImageUploadedByTalkFord.com1490388367.591371.jpg
The rears where more dirty than rusty!.

ImageUploadedByTalkFord.com1490388416.729144.jpg
Cleaned & ready.

ImageUploadedByTalkFord.com1490388475.090893.jpg

ImageUploadedByTalkFord.com1490388503.204977.jpg
Job done, all four now done

The next big job is it needs a mega valet 😳

Attached Thumbnails

  • ImageUploadedByTalkFord.com1490387668.280903.jpg

2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue

#3 tazzman600

tazzman600

    Clever cloggs

  • Members
  • 2115 posts
  • Vehicle Driven:Mk4.5 tit x sport
  • Name:Mad Vlad
  • Location:Rochdale

Posted 24 March 2017 - 10:57 PM

Hi steel and welcome to the forum. Yeah lunar sky is one helluva colour. My tit x sport is that colour and it looks different everytime I look at it.
You've done quite a bit to your car already and a good job done. I had a 140 hp diesel mondeo but soon got it remapped to 140 at the wheels and what a transformation. Keep up the good work and enjoy your car.

#4 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 25 March 2017 - 10:37 AM

*
POPULAR

Cheers tazzman,

Never thought about getting it remapped ?,

Thanks steve
  • tazzman600 likes this
2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue

#5 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 29 December 2017 - 02:23 AM

Hi everyone,

Not been on for a long time !, the Mondeo has been running great ! Doing what it should be doing!

But last week a warning message came up on the dash saying engine malfunction! And a yellow warning light as well!
The engine management light didn’t come on just a warning light !

So had it checked out and it’s with the dpf system!, I had the light turned off but it came back on after 5mins !
The guy said put some cataclean in with a 1/4 tank of fuel,
So done that and the message and light are still on after I start the car !

Anyone else had this ? And what was wrong ??

It’s book in on Tuesday to get checked out so finger crossed it’s not going to be expensive 😫

Thanks Steve
2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue

#6 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 13 April 2019 - 02:28 PM

Hi,

I didn’t have a chance to update the problem last year!

This was the fuel vaporiser, which then clogged the DPF.
Ford wanted £340+ for the vaporiser 🤪, got one off eBay for £180,
And has been running great for over a year now!

I had an advisory on the mot last year for the rear trailing arm bushes,
Have also noticed the front strut top mount a bit rough.
54453AD5-18AB-4E80-A612-037E544BDFD3.jpeg

I have a caravan and the rear end sits a bit low, even when the van is empty!
But bear in mind if the rear springs are the original ones ! they are 7 years old and the car has 155000 miles !

I have read up on fitting MAD springs but at £260 is there any other alternative options?

Thanks Steve
2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue

#7 PURPLE_2L_LX

PURPLE_2L_LX

    Mk3 Forum Moderator

  • Global Moderator
  • 28075 posts
  • Vehicle Driven:MK4.5 TDCI 140
  • Location:westmidlands

Posted 13 April 2019 - 11:46 PM

Some places can make springs to your requirements, other than that just get

some genuine springs.

 

If your noseweight is correct then it should not sag too much.

 

Just watch the weight, it soon adds up.

 

500 - 600 kg may sound like a large payload, but add 75-80kg noseweight and 3 or 4

passengers and a boot of luggage, roofbox?

 

Very easy to exceed the axle limits.


MK4.5 TDCI 140 Business Estate.

 

MK3 FUSE INFO CLICK HERE ... FORD WIKI CLICK HERE .... FORD ETIS CLICK HERE

Adding your location may find someone local who could offer assistance.

F-Super, Bluetooth OBDII (ELM) and a MS509 scanners (test subjects required).

ForDiag now available to victims.


#8 Lucygrace

Lucygrace

    Just Joined TF!

  • Members
  • 9 posts
  • Vehicle Driven:Mk4 mondeo
  • Name:Dan
  • Location:Warrington

Posted 17 April 2019 - 06:25 AM

Good work, that's 1 of my next jobs to do the top mount.

#9 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 17 May 2019 - 05:07 PM

Well I have got the strut top mounts and bearings fitted,
Also the rear trailing arms !
While they were apart I fitted new coil springs front & rear ! 😋

Rear brakes had started to squeal when cold,
Thought might just need a clean ?,
Oh no ! They were almost too the metal !!

The front pads were almost the same as when they were fitted 2 years ago (30,000miles)

Anyway have change the fronts as well as the rears ! 😎

Next job is oil & filters, that will be next weekend ;

Attached Thumbnails

  • IMG_20190517_175701.jpg
  • IMG_20190517_175723.jpg

2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue

#10 Ste L

Ste L

    Likes to chat

  • Members
  • 78 posts
  • Vehicle Driven:Kuga Titanium TDCI
  • Name:Steve Lester
  • Location:UK

Posted 08 October 2019 - 06:40 PM

Well it’s time to say goodbye to the mondeo !
DB06B381-7B89-41E6-89BE-6F587EA271B3.jpeg


And hello to the kuga
7F6DA498-49C8-4796-A724-1E8D896CF910.jpeg

Will start a new diary soon !
2013 Kuga Titanium 2.0 TDCI 163 Auto 4X4, Blazer Blue




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users