Enabling Navigation in Convers+ stops Climate control working - In-Car Entertainment (Mk4 Mondeo) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Enabling Navigation in Convers+ stops Climate control working

elmconfig sat nav convers+ climate control

  • Please log in to reply
7 replies to this topic

#1 Mattstroud81

Mattstroud81

    Likes to chat

  • Members
  • 51 posts
  • Vehicle Driven:Mondeo MK4 TitX
  • Name:Matt Stroud
  • Location:Deal, Kent UK

Posted 12 November 2016 - 04:17 PM

Hi All,

 

I thought i would start a new thread for this, even though it is a continuation from my current additions to my mondeo, i though it would be worth a new thread as its a very specific issue. I have replaced my stereo in this mondeo with the Travelpilot FX Sat Nav head unit and it works great, the next thing i wanted was the navigation instructions in the convers+ display. 

 

After finally getting ELMConfig working (i've settled on v0.2.05 working well at speed 38400) i have read my BCM which has filled the Central Configuration fields with the details from my car. 

 

The In Car Entertainment dropdown is normally set to 'High Level CDx6 + AM/FM Radio' 

 

elm%201.jpg

 

There is only one option in the list that mentions Navigation which is 'Nav High Level CD + AM/FM Radio'

 

elm%202.jpg

 

If i select this and write CCC to BCM, i do get the Navigation instructions in the Convers+ display which is great, but a big problem is that the climate control module below the stereo is completely dead, no backlight, no nothing :-(, if i load ELMConfig again and set the stereo back to the one it was originally and re-save it to BCM all is working again, climate control powers up and works normally, but obviously i then haven't got the navigation on the Convers+ display.

 

Does anyone know why this happens and what i might need to do to fix this? thanks in advance for any advice from all you clever lot!!



#2 apollogary

apollogary

    MEG Corporal

  • Gold Member
  • 1544 posts
  • Vehicle Driven:Mondeo
  • Name:Gary
  • Location:Brentwood, Essex

Posted 12 November 2016 - 04:37 PM

I think hi level nav is for the NX touch screen version with built in climate controls. You probably want low level. Also, in case you didn't realise CDx6 is if you have a multi changer in the boot


2008 2.0 TDCI Ghia Auto in Kelp
18" alloys, full biscuit leather,8 way electric climate seats, sunroof, NX nav, voice, keyless start, F & R PDC, TPMS, privacy glass
Mods.
Facelift convers+. Rear door roller blinds. Rear footwell lights. Rear Ambient lighting. USB, bluetooth & BT streaming. Memory drivers seat and mirrors. Auto folding mirrors with indicators. Door warning lights front and rear. Variable heated rear seats. PTC electric heater. Facelift front and rear bumpers and bonnet with DRLs and  headlight washers. Facelift tailgate and rear LED lights. 
Keyless Entry. Power child locks, Cooled glove box, Air Quality Sensor, Facelift MCA2 with 9 speakers, DAB and Ford rear view camera. Facelift upper and centre console trims and upper door panel trims in walnut.
Adaptive Cruise Control, Forward Alert & Hill Launch Assist. Xenon Lights. Interactive Vehicle Dynamic Control. Electric Park Brake, Rear Seat Entertainment, 13 pin Detachable Tow Bar and Module 

 

Photos in Gallery


#3 Mattstroud81

Mattstroud81

    Likes to chat

  • Members
  • 51 posts
  • Vehicle Driven:Mondeo MK4 TitX
  • Name:Matt Stroud
  • Location:Deal, Kent UK

Posted 12 November 2016 - 05:05 PM

I think hi level nav is for the NX touch screen version with built in climate controls. You probably want low level. Also, in case you didn't realise CDx6 is if you have a multi changer in the boot

 

Hi Apollogary,

 

Thanks for your help with the ambient lighting connector the other day, i found the connector you were describing and connected this and i now have the ambient lighting working which i think looks great :-)

 

 

 

As for this issue regarding the sat nav, when i bought the car it had a rubbish aftermarket stereo fitted so i didn't know what stereo it originally had fitted and it certainly doesn't have a cd changer fitted in the boot when i bought it (unless its well hidden??). I removed the aftermarket stereo (and the parrot bluetooth that was also fitted) and installed the FX sat nav (5" non touchscreen) which works great. I have also fitted a ford bluetooth module which is working with the stereo (just need to modify a loop connector and fit a microphone as mentioned in the other thread) to complete this.

 

I suppose what i need to know for this current issue is, what option or options would i need to choose to enable the convers+ navigation with the FX sat nav, and keep the separate climate control working?



#4 apollogary

apollogary

    MEG Corporal

  • Gold Member
  • 1544 posts
  • Vehicle Driven:Mondeo
  • Name:Gary
  • Location:Brentwood, Essex

Posted 12 November 2016 - 06:40 PM

I'll try to have a look later. In the meantime, you could try this. Have a look on autotrader for a car of similar year that has what you want to have. Put the registration number into ETIS, which will give you all the features of that car, including chassis number. load elm config and use offline. Enter that chassis number in, can't remember exactly where without seeing it, but it should then give you that cards as-built settings. Just see what audio option is ticked


2008 2.0 TDCI Ghia Auto in Kelp
18" alloys, full biscuit leather,8 way electric climate seats, sunroof, NX nav, voice, keyless start, F & R PDC, TPMS, privacy glass
Mods.
Facelift convers+. Rear door roller blinds. Rear footwell lights. Rear Ambient lighting. USB, bluetooth & BT streaming. Memory drivers seat and mirrors. Auto folding mirrors with indicators. Door warning lights front and rear. Variable heated rear seats. PTC electric heater. Facelift front and rear bumpers and bonnet with DRLs and  headlight washers. Facelift tailgate and rear LED lights. 
Keyless Entry. Power child locks, Cooled glove box, Air Quality Sensor, Facelift MCA2 with 9 speakers, DAB and Ford rear view camera. Facelift upper and centre console trims and upper door panel trims in walnut.
Adaptive Cruise Control, Forward Alert & Hill Launch Assist. Xenon Lights. Interactive Vehicle Dynamic Control. Electric Park Brake, Rear Seat Entertainment, 13 pin Detachable Tow Bar and Module 

 

Photos in Gallery


#5 dutchguy

dutchguy

    Likes to chat

  • Members
  • 421 posts
  • Vehicle Driven:Ford Mondeo mk4 2.5t
  • Name:Lars
  • Location:not near Amsterdam!

Posted 12 November 2016 - 07:06 PM

You need low level nav setting to make it work.

#6 Mattstroud81

Mattstroud81

    Likes to chat

  • Members
  • 51 posts
  • Vehicle Driven:Mondeo MK4 TitX
  • Name:Matt Stroud
  • Location:Deal, Kent UK

Posted 12 November 2016 - 07:43 PM

I'll try to have a look later. In the meantime, you could try this. Have a look on autotrader for a car of similar year that has what you want to have. Put the registration number into ETIS, which will give you all the features of that car, including chassis number. load elm config and use offline. Enter that chassis number in, can't remember exactly where without seeing it, but it should then give you that cards as-built settings. Just see what audio option is ticked

 

That sounds like quite a plausible idea! Rather convoluted, but it would show me exactly what options would be needed! I might just have to try it out :-)

 

 

 

You need low level nav setting to make it work.

 

Thanks for this, although in ELMConfig v0.2.05 that i am using (and seems to be the only one i can get working!) Low level Nav doesn't appear as an option, only High Level Nav + Radio.

 

I wonder if later versions of ELMConfig have other options available? I will investigate.

 

Thanks for the advice as always guys :-) 



#7 Mattstroud81

Mattstroud81

    Likes to chat

  • Members
  • 51 posts
  • Vehicle Driven:Mondeo MK4 TitX
  • Name:Matt Stroud
  • Location:Deal, Kent UK

Posted 12 November 2016 - 09:34 PM

So to update further on the Navigation in Convers+ vs Climate control issue, DutchGuy is absolutely right, i needed to select Nav Low Level in order for it to work properly. The trouble though was that ELMConfig v0.2.05 didn't have this option in the list!

 

Looking at later versions, v0.2.13b did have Nav Low Level as an option but this version wouldn't read from my car, just gave errors, v0.2.14 gave different errors, but still couldn't work. So in the end i opened v0.2.13b in Offline mode, loaded my BCM's backup CCD file (*.elm file), then selected the Nav Low Level, saved a new CCD to file with this setting, then connected back to my car using v0.2.05, loaded the file with the Nav Low Level (the In Car Entertainment option was now greyed out - i guess because it has a value that this version doesn't know) write it to the BCM and sure enough all is working perfectly! climate control all working as normal, navigation directions in the Convers+ :)  I am very happy indeed.

 

The next project is to finish the bluetooth install. The headunit already shows my phone connected and can list phonebook items, call lists etc, and i have phone option in Convers+. just need to install microphone (anyone got one for sale?!) and modify loop connector to get the audio coming out the speakers instead of static. Still got to find where this is located first  :lol:

 

I love tinkering with this stuff! so much fun :biggrin:  :biggrin:

and thank you everyone who has helped me with all your advice and information, such a valuable resource here.


Edited by Mattstroud81, 12 November 2016 - 09:37 PM.


#8 smetin

smetin

    Just Joined TF!

  • Members
  • 9 posts
  • Vehicle Driven:Ford Galaxy
  • Name:Salim Metin
  • Location:The Netherlands

Posted 03 March 2021 - 05:48 PM

Hi guys,

I'm new at this forum and my English not very best, apologies for that.

Recently I've replaced my old speedometer with Ford Convers+  (comes out from Mondeo 2010 tdci).

My car is Galaxy mk3 tdci of 2009. The speedometer works fine, except issue with airbag light (I  already opened a new topic for that)

 

I'm in this topic interested in enabling navigation at Convers+ display.

My Galaxy is equiped with Travelpilot FX. The Convers+ I installed is from 2010 Mondeo. Is it possible to enable navigation at my car too? What exactly do I need? ELMC327 (ford), Forscan application, what more?

 







Also tagged with one or more of these keywords: elmconfig, sat nav, convers+, climate control

2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users