Changing the Fuel Filter - 1.8L / 2.0L Duratec Petrol Engines (Mondeo Mk3) - TalkFord.com

Jump to content

TalkFord.com uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

TalkFord Gold Members Don't See Adverts! Subscribe Today To Hide This Advert!

News Feed (View All Updates)



Photo

Changing the Fuel Filter


  • Please log in to reply
8 replies to this topic

#1 ron130888

ron130888

    Just Joined TF!

  • Members
  • 1 posts
  • Vehicle Driven:Mondeo MK3 2.0
  • Location:England

Posted 17 February 2012 - 01:33 PM

Hi,

I will be attempting to change the fuel filter on my 2.0 tomorrow.

Would anybody here be able to tell me firstly where on the car it is located, what tools are needed, how long this would take any any other hints or tips regarding it?

I've never changed a fuel filter before so any advice would be greatly appreciated.

Many thanks

Ron

#2 stripe88

stripe88

    Big Megger

  • Members
  • 2885 posts
  • Vehicle Driven:mondeo 2l ghiax
  • Location:worcestershire

Posted 17 February 2012 - 02:42 PM

*
POPULAR

10 min job, fuel filter under rear driver door, can jack car up but i can do it on the ground, squeese plastic pipe clip inner and push halfway out, wiggle pipes off each end, two bolts hold the bracket to car floor, undo and drop the filter and bracket in one,6mm to undo the bracket, and mole grips handy to do back up to clamp the bracket in place.
make sure filter is the right way round,look for the arrow.

also pull the fuse in engine bay with a petrolpump logo and run engine until it stops to depresurise fuel line.
  • M.Lowe likes this

#3 M.Lowe

M.Lowe

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Mondeo MK3 2.0i
  • Name:Max
  • Location:Leyland

Posted 15 August 2014 - 06:14 PM

I've just changed mine following this method and all went ok.  The only thing is now after the engine has been running I get a short strange noise when I turn the engine off - the noise is coming from the fuel filter area or thereabouts.  I've checked all of the fuel lines into and out of that area and all looks ok, no leaks or anything.  The new filter is a genuine Ford one and I've checked and double checked that it is the exact and correct one for the car and it is.  The old filter was a Mahl one and made no noises.  Has anyone got any ideas and is this a problem or am I worrying over nothing??


Edited by M.Lowe, 15 August 2014 - 06:15 PM.


#4 M.Lowe

M.Lowe

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Mondeo MK3 2.0i
  • Name:Max
  • Location:Leyland

Posted 15 August 2014 - 07:36 PM

I've just been out in the car again, and following turning the engine off I noticed the noise again however it actually seems to be coming from the engine and sounds a bit like air pressure dying away - it's very odd and I really can't put my finger on it.  Any ideas would be welcomed, the only thing I could maybe put it down to is air being in the fuel system following the fuel filter change, but I would've expected that on a petrol engine it would've got rid of any air in the system as soon as the engine started and the fuel started to flow through.



#5 Mark24v

Mark24v

    Megger

  • Members
  • 748 posts
  • Vehicle Driven:02 Mondeo V6 Zetec S
  • Location:Antrim

Posted 16 August 2014 - 03:19 PM

M.Lowe......is the filter on the correct way round (an arrow shows the flow direction),just a thought.


2002 Mondeo Zetec S 2.5 V6

 

2004 MR2 Roadster+ hardtop+chrome style/roll bar 30000 miles.

1995 Ford Probe 16v 

1998 Toyota Rav4 Freesport AWD (daily driver)


#6 siruncle

siruncle

    munching bananas

  • Global Moderator
  • 18998 posts
  • Vehicle Driven:St150
  • Name:Pete
  • Location:Rutland

Posted 16 August 2014 - 07:37 PM

just be careful if doing this as the filter connections on the fuel lines can be a bit of a pain to release


<p><p>From Rutland, Leicestershire or Northamptonshire? Join the Rutland Group, http://www.talkford....land-area-page/ Leicestershire, http://www.talkford....leicestershire/ or Northamptonshire, http://www.talkford....rthamptonshire/2000 (W) Mondeo Mk2 Ghia 2.0 Hatch in Stardust Silver, now has company, a 2000 (W) Transit Smiley :) 2.5di (ish), in diamond white, with a blue stripe. (pics coming soon). Also 05 Fiesta St150 in colorado red. This is Ford country, listen quietly and you can hear Vauxhalls rusting :)

#7 M.Lowe

M.Lowe

    Just Joined TF!

  • Members
  • 3 posts
  • Vehicle Driven:Mondeo MK3 2.0i
  • Name:Max
  • Location:Leyland

Posted 17 August 2014 - 10:54 AM

The filter is on the correct way around, arrows pointing in the correct direction, etc.  It runs fine, no engine management lights or anything.

 

Whilst I'm looking at this I've also removed and cleaned the T-Map sensor - all in the hope of some more MPG!!

 

Are there any other things which I can easily remove & clean to improve my MPG??



#8 Flounder

Flounder

    Likes to chat

  • Members
  • 253 posts
  • Vehicle Driven:Focus Mk2.5 Titanium
  • Location:glasgowcity

Posted 18 August 2014 - 09:40 PM

I could not get the new (aftermarket) fuel filter to fit in the bracket by wrapping the steel band around it and then screwing in the 6mm bolt, it was too tight a fit to get the screw holes to line up. I had to screw the bolt in a little with the bracket band empty, then rotate the filter all the way in with a rubber belt oil filter tool. Other than that, as above (depressurise the system first by pulling the fuse then letting the engine run till it conks out). It was my first time changing a fuel filter too.

 

http://www.talkford....il-filter-tool/



#9 compuwiz_uk

compuwiz_uk

    Global Mod

  • Global Moderator
  • 19696 posts
  • Vehicle Driven:2001 1.8 Mk3 Mondeo
  • Location:West Yorkshire

Posted 20 August 2014 - 06:07 PM

The filter is on the correct way around, arrows pointing in the correct direction, etc.  It runs fine, no engine management lights or anything.

 

Whilst I'm looking at this I've also removed and cleaned the T-Map sensor - all in the hope of some more MPG!!

 

Are there any other things which I can easily remove & clean to improve my MPG??

 

next time try pressing the go pedal just after the engine conks & see if the noise changes from the odd noise to a THUNK noise of lots more air escaping in one go & then no more of the odd noise.

 

 

its possible that your just hearing trapped intake air noise which is perfectly normal & may just be you have disturbed somat while messing  ( common things if its this is the idle air control valve or the throttle body itself ( often if using a jubilee clip on the throttle body end of the pipe as its often applied to tight & creating a gap for air escape ) - it could also be highlighting you have a split in the intake manifold to PCV valve unit pipework ( common problem on updated intake systems / facelift model cars  & can also cause high revving troubles ( perm or random ) as well as bad MPG too if bad enough as its letting in unmetered air & fecking up the fuelling map  :(  )

 

 

to further help with the MPG then we need more info though.

 

ie, wheels/tyre size

journey types

gearbox type ( auto / manual - auto's are thirsty buggers compared with manuals - especially round town )

driving style - miss daisy staying below 3k always / stole it & never usually below 3k

current consumption figure

how is current consumption being calculated ( using the trip on the dash or manually with tank to tank fills & a calc )

 

 

example, my mota has slightly oversized 17" alloys/tyres combo, manual box, its usual journeys are round town driven steadily often staying below 3k for changes but like I stole it from time to time showing it some redline but still gets around 30mpg when calculated & the dash is often out by 1 or 2 mpg either way. - get it on a motorway for a jaunt & it can see high 40's & has even touched 50mpg once over a journey - mixed motorway/round town normally see's high 30's to low 40's depending on the mix ratio etc. all this is about/above book figures for a new mota let alone a 2001 model with 185k miles + done. ( never touched the t-map / egr but have replaced the intake due to the dreaded flaps problem appearing suddenly & also fitted a new idle control valve ( which did not fix the high idle caused by the holed intake manifold  :}  )


Too many mods to list in here but they can be seen here


Most Common MK3 Question / Problems have solutions listed in the WIKI - Click Here

Ford Etis Vehicle Information - Click Here





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users